The minimum browser requirements are:

  • Chrome 38
  • Firefox 31
  • Safari 7
  • Edge
  • IE 11 

For website, HTML and 3D content proofing, you must be using Chrome or Firefox, with the appropriate browser extension installed:

Install the Chrome extension here.
Install the Firefox extension here.

Note: Edge and Safari extensions are coming soon.

We recommend Chrome or Firefox as the browser of choice for all PageProof users.

Did this answer your question?