The minimum browser requirements are:

  • Chrome 38
  • Firefox 31
  • Safari 7
  • Edge
  • IE 11 

For website, HTML and 3D content proofing, you must be using Chrome, Firefox, or Microsoft Edge, with the appropriate browser extension installed:

Install the Chrome extension here.
Install the Firefox extension here.
Install the Microsoft Edge extension here.

Note: A Safari extension is coming soon.

We recommend Chrome, Firefox or Microsoft Edge as the browser of choice for all PageProof users.

Did this answer your question?